DirectX 診斷工具

Microsoft DirectX 診斷工具說明文件包含下列主題：

  • DirectX 診斷工具概觀
  • 使用 DirectX 診斷工具來診斷問題
  • 測試 DirectX 元件
  • 覆寫預設行為
  • 儲存資訊
  • 檢查 WHQL 數位簽章


DirectX 診斷工具概觀

「Microsoft DirectX 診斷工具」提供系統上 DirectX 應用程式介面 (API) 元件及驅動程式的相關資訊。它可讓您測試音效及圖形輸出，以及 Microsoft DirectPlay 服務提供者。它也可以讓您關閉一些硬體加速功能。

您可以使用診斷工具，以在支援呼叫期間為技術人員蒐集資訊。且可以儲存該工具所蒐集的資訊，並將它貼至電子郵件訊息。

資訊在一系列頁面上顯示。您可以一頁一頁地移動，方法是：

  • 按一下索引標籤。
  • 按一下 [下一頁]。
  • 當焦點位於索引標籤上時，按向左鍵或向右鍵。

診斷工具裡的某些頁面，如 DirectX 檔案、音樂或輸入，會在表格中顯示資訊。您可以排序那些表格中的資訊，以便更容易找到您要尋找的特定詳細資料。

排序表格中的資訊

  1. 識別包含您要使用之資訊的直欄來排序表格。
  2. 按一下直欄頂端的標頭按鈕。

    表格就會依該直欄之項目的字母或數字順序來排序。若要反轉排序順序 (例如，從 Z 到 A，而不是從 A 到 Z)，則再按一下該標頭按鈕。

* 注意事項

  • 部份資訊 (如顯示卡上的記憶體數量) 可能為大約值。
  • 若要知道更多儲存「DirectX 診斷工具」所蒐集之資訊的相關資訊，請按一下 [相關主題]。

相關主題

測試 DirectX 元件

儲存資訊


使用 DirectX 診斷工具來診斷問題

如果在執行 Microsoft DirectX 應用程式時遇到問題，「DirectX 診斷工具」可協助您尋找問題的來源。您應該搜尋的部份內容如下：

  • DirectX 元件的錯誤版本。在 [DirectX 檔案] 頁的 [注意事項] 區段中，搜尋測試及偵錯檔案的警告。Beta 檔案是早期的測試版本，不可與商業程式一起安裝。偵錯版本 (用於程式開發) 不可與最後的產品一起安裝。元件的偵錯版本會造成程式的執行速度遠比零售版本慢。
  • 缺少硬體加速功能。除非可以使用 Microsoft DirectDraw 或 Direct3D 硬體加速，否則部份程式的執行會十分緩慢 (或根本無法執行)。在 [顯示] 頁上，查看 [DirectX 功能] 下的 DirectDraw、Direct3D 或 AGP 材質加速是否標記為 [無法使用]。若是如此，您可以考慮升級您的硬體。或是如果您使用 Windows Server 2003 系列產品，則可能需要啟用圖形加速。若要執行此動作，您可以開啟 [控制台] 中的 [顯示]，選取 [設定值] 索引標籤，再按一下 [進階]。選取 [疑難排解] 索引標籤，再將 [硬體加速] 滑桿移動至 [最大]。
  • 裝置尚未連線。如果搖桿或其他輸入裝置無法回應，則可能尚未正確設定。請確定該裝置在「DirectX 診斷工具」的 [輸入] 頁上。如果沒有的話，則透過 [控制台] 新增該裝置。
  • 未簽章的驅動程式。Microsoft 尚未使用 DirectX 的最新版本來測試未簽章的驅動程式是否完全相容。建議您使用已由 Microsoft Windows 硬體品質實驗室 (WHQL) 數位簽章的驅動程式。

* 注意事項

  • 如果您使用「終端機服務」在支援硬體加速功能的遠端系統上運作，則「DirectX 診斷工具」可能會指出硬體加速功能的支援。不過，「終端機服務」無法使用硬體加速功能，因此無法支援。

相關主題

儲存資訊

檢查 WHQL 數位簽章


測試 DirectX 元件

可以在已連接至您系統的每個監視器上測試 Microsoft DirectDraw 及 Direct3D。也可在每個音效輸出裝置上測試 DirectSound，並在每個音樂連接埠上測試 DirectMusic。

測試 DirectX 功能

  1. 按一下適當頁面上的 [測試] 按鈕。
  2. 讀取任何出現的訊息。
  3. 觀看或聽取測試。
  4. 在看到詢問測試是否成功的訊息之前，請讓每個測試持續執行。如果您回應 [否]，則不會再執行測試。

DirectMusic 僅有單一測試。當您對正確播放 (或未正確播放) 的音樂感到滿意，請按一下 [確定]。

您可以在任何可使用的服務提供者上測試 Microsoft DirectPlay 的功能。

測試 DirectPlay

  1. 在 [網路] 頁上，按一下 [測試 DirectPlay]。
  2. 在 [DirectPlay 測試] 對話方塊中，鍵入使用者名稱，並選擇服務提供者。
  3. 選取 [建立新工作階段]，再按一下 [確定]。
  4. 如果已選擇了數據機連線，則在 [數據機連線] 對話方塊中按一下 [回答]，以將數據機轉換為自動回答模式。

現在於另一部電腦上執行「Microsoft DirectX 診斷工具」，該電腦可建立與第一部電腦的選定連線。

  1. 按一下 [測試 DirectPlay]。
  2. 鍵入不同的使用者名稱。
  3. 選擇相同的服務提供者。
  4. 按一下 [加入現存的工作階段] 按鈕，再按 [確定]。

    若是部份連線類型，系統可能會要求您提供相關資訊 (如電話號碼)。若為本端網路上的 TCP/IP 連線，您可以將文字方塊留為空白。

  5. 在包含您於第一部電腦上建立之工作階段名稱的 [工作階段清單] 中，選取該工作階段的名稱。
  6. 兩台電腦都應立即顯示聊天對話方塊。在電腦上的輸入方塊中鍵入訊息，再按 [傳送]。訊息應出現在兩台電腦上聊天對話方塊的捲動區域中。


覆寫預設行為

在 [音樂] 頁上，您可以藉由移動滑桿來設定硬體加速的不同等級。您必須是系統管理員，才能變更硬體加速等級。此等級在關閉「Microsoft DirectX 診斷工具」之後，仍持續有效。

您可以停用 Microsoft DirectDraw 或 Direct3D 的硬體加速 (如果可使用此類硬體加速)。若要做這樣的處理，請移至每個顯示裝置的 [顯示] 頁，並按一下 [停用]。停用硬體加速後，即使您已關閉「DirectX 診斷工具」，應用程式亦無法再使用該硬體加速。若要重新啟用硬體加速，請在適當的 [顯示] 頁上按一下 [啟用]。

* 注意事項

  • 停用 DirectDraw 加速亦會停用 Direct3D 的加速。

您亦可覆寫由 DirectDraw 全螢幕應用程式所設定的監視器重新整理速率。僅當您遇到應用程式的顯示問題，且有理由相信該應用程式設定了無效的重新整理速率時，您才應該做這樣的處理。

設定覆寫重新整理速率

  1. 在 [其他說明] 頁中，按一下 [強制覆寫]。
  2. 在 [強制覆寫 DirectDraw 的重新整理行為] 對話方塊中，選取 [強制覆寫數值]，並為監視器輸入有效的重新整理速率。
  3. 按一下 [確定]。

取消覆寫重新整理速率並讓 DirectDraw 應用程式來設定自己的重新整理速率

  1. 在 [其他說明] 頁中，按一下 [強制覆寫]。
  2. 在 [強制覆寫 DirectDraw 的重新整理行為] 對話方塊中，按一下 [預設值]。


儲存資訊

  1. 若要儲存使用「Microsoft DirectX 診斷工具」所蒐集的資訊，按一下 [儲存所有資訊]。
  2. 所有頁面的資訊都會儲存在含您所選擇之名稱及位置的檔案中。若要另存為 XML 檔案，則在 [存檔類型] 中，按一下 [XML 檔案 (*.xml)]。

* 注意事項

  • 也可以藉由在命令提示字元中，鍵入下列命令來儲存資訊：

    dxdiag [/x outfile] [/t outfile]

    在此命令中，/x 會將資料傳送為 XML 檔案，/t 將資料傳送為文字檔，而 outfile 則會指定該檔案的名稱及位置。


檢查 WHQL 數位簽章

當要驗證您的驅動程式是否已有 Microsoft Windows 硬體品質實驗室 (WHQL) 數位簽章，「DirectX 診斷工具」就會試著連線到網際網路來下載新的 WHQL 憑證。執行此處理程序期間，不會從您的系統擷取任何資訊。此工具會在您第一次使用它時，詢問您連線至網際網路的權限。僅會向您詢問一次。若要變更您的回答，請至 [系統] 頁，選取或清除 [檢查 WHQL 數位簽章]。

也可以藉由在命令提示字元中，鍵入下列命令來變更：

dxdiag [/whql:on] [/whql:off]

在此命令中，/whql:on 允許「DirectX 診斷工具」檢查 WHQL 數位簽章，而 /whql:off 則不允許「DirectX 診斷工具」檢查 WHQL 數位簽章。